What web browsers does Scholastica support?Last Updated: Dec 18, 2017 02:25PM CST

Scholastica isn't compatible with older web browsers. In order to use Scholastica you must upgrade to a newer browser.

Upgrading your browser to a more modern version increases your security, makes your browsing experience faster, and allows you to take advantage of features that we as web developers can provide to give you an amazing experience.

You may click any of the icons below to download a modern, supported browser:

If your institution won't allow you to use a different browser, please let us know by contacting us here.

Why isn't my browser supported?

Like many major web websites including Google, Scholastica does not support older browsers that cannot use the many new improvements and technologies which are necessary to provide a fast, excellent user experience.

Here is a detailed breakdown of exactly which browsers (and versions) are supported:

Browser Support status by version
FireFox
  • >= 22 – Fully supported.
  • < 22 – Unsupported. Users will be redirected and prompted to upgrade their browser.
Internet Explorer
  • >= 11 – Supported for all pages except published HTML articles on Scholastica, like the example here.
  • < 11 – Unsupported. Users will be redirected and prompted to upgrade their browser.
  • NOTE: As of 1/12/16, Microsoft no longer supports Internet Explorer 10 and older.
    You can read more here.
Google Chrome Fully supported.
Safari
  • >= 4.0 – Fully supported.
  • < 4.0 – Unsupported. Users will be able to view the site but may experience problems.
support@scholasticahq.com
http://assets2.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete